Rhino Arc won't charge...

Comments

18 comments

  • Avatar
    Chad Madden

    I'm having the exact same problem. Mine is 2 weeks old. First charged all the way. Now after use I've let it charge for like 8 hours and it sits at 40%. Won't move...

  • Avatar
    Spiro Angelatos

    I have the identical problem and even ordered a new charging cable from Rhino in the hopes it would remedy the problem. It did not.

  • Avatar
    create

    I have a dead ARC also, bought 11 months ago. Used a handful of times, display lights up when connect to wall charger. Flashing Full/Empty. nothing happens though. no charging. does not turn on either. have contacted support.

  • Avatar
    mark

    Same here, I've purchased 2 Rhino Arc's and both have the same recharge issue I've now left them on for 24 hrs and they don't charge more than 30%.

     

    Any update on this Rhino

  • Avatar
    Chad Madden

    So I changed out my USB cable twice. Also using an Apple wall charger. I plugged it in this morning and finally it has charged up from 40% to about 90%. I left it in all day. I have no idea the exact reason. I thought it was a software update issue, but just wanting to give an update. 

  • Avatar
    mark

    Thx Chad I'll try that as well!

     

    I've had my two Rhino ARC's plugged in for 40 hrs now, one still has 30% charge but the other has crept up to 50%

    I'm going to try and charge one now using an Apple USB wall charger to see if get the same result as above!

     

    Any update on this Rhino?

  • Avatar
    Christoph Hartmann

    I also have this problem. I tested it with 3 different charges, but the ARC never charge more than 30 - 40%. 

    Does the Apple USB charger fix the problem?

  • Avatar
    Darren E Cowley

    Returned one Arc with this issue, second one is exactly the same, obviously not up to the job. There should be a real imho.

     

    Cheers

    D

     

  • Avatar
    mark

    Hey, i've  sorted this issue 

    I bought two of these Arc's, I had exactly the same issue as what's been described above!

    The Arc would not charge more than 30%!

    Now, this is what I think I did wrong, with both ARC's I switched them on and I started to test/play with them out straight out of the box, I believe now, this triggered a battery memory problem, and i guessing everyone else above prob did the same thing! What I should have done is give them a full charge first (I believe). Anyway, this isn't important, what is important is what I did to correct the issue!

    So when I came to charge them after I had been using them out of the box I got the 30% charge issue! I had nearly given up on them when after 20 hrs of charging one of the arc had moved up to 40% shortly followed by the other ARC also reaching 50% so ended up leaving them on for nearly 4 days and 5 days charging to get them both up to 100% charged, then I phoned Rhino and they said now soak test them, so I set the two ARC's up on a loop movement and 4.5 hours later both were completely dead, then I charged them again both of them charged to 100% in 4.5 hours, ever since then they've charged fine.

    Hope this helps all above

     

     

     

     

     

  • Avatar
    mark

    I did use an apple charger but I really don't think that was the issue, I'm 90% its a battery memory issue in the ARC, tbf the worst battery memory issue I've ever seen i a bit of pro kit looking at all the above!

    I now use any USB chargers and they all work fine and take 4 to 4.5 hrs each time to charge the ARC to 100% and each time the ARC gives me 4 hours of operation approx

  • Avatar
    Jeff Riegel

    Mine is now 100% dead and I can't even turn the thing on to discharge (per Mark's instructions above).  I charged mine up out of the box. Stayed at 30%, now at 0%. I've only used this thing 2-3 times in the last year.  I was going to recommend this even more than I already have, but I'm embarrassed that others I know in the biz are having the same issues making me look bad for the recommendation!

    Funny-- this is a RHINO forum on the RHINO website... yet RHINO hasn't responded to this issue???

    Money twice lost--  money buying this and and client money. I'll be blogging about this...

    Whats the fix, RHINO?

  • Avatar
    Christian Pokrywka

    Hmm I'm having the same issue! Haven't used my Arc in probably a year and now it's having a very hard time charging. Was hoping to use it on a shoot tomorrow but looks like that isn't going to happen. Frustrating...

  • Avatar
    LEW

    Ok, I have the same problem. Mine does not start anymore. When plugged in, it displays a full load bar, but it still refuses to light up.

    Frustration is the word.

     
  • Avatar
    Umair Saleem

    Hey guys,

    Hope everyone is doing well. I just wanted share with you all that I had the same problem with my arc not charging. I managed to fix it by changing the charger, the normal apple and other chargers are giving 1amp and I think the one I used was giving 1.5 and that charged the rhino with no issues. Also I noticed that if you plug the cable in the charge symbol comes on even if the power is not on from the switch. So I’d plug the cable whilst plug not in the wall and make sure the symbol doesn’t come on then plug it in and switch on. This seems to charge it absolutely fine. Hope this helps.

  • Avatar
    mark

    Another update from above, my solution where I thought I'd fixed the issue was successful I've found myself in the same situation where both my ARC's won't charge again and even leaving them on for days charging doesn't work, they now won't charge more than 5/10%, sorry back to square one!

  • Avatar
    Darren E Cowley

    Best option is to try and get your money back and invest it in an Edelkrone, yes it's more expensive but you get what you pay for and the quality of their gear above this Rhino stuff is lightyears away....

    Cheers

    D

     

  • Avatar
    Umair Saleem

    Hey mark, plz see my post above on how I fixed it. Don’t use the apple charger or any charger that’s just outputting 1amp. Also plug the cable in arc and make sure the screen doesn’t come on until the plug is in the socket and switched on. I was very worried with this issue but it has been resolved for me.

  • Avatar
    mark

    Hi Umair,

    Yes, I did try this, but what happened for me and it was repeated on both my ARC's they started to charge went up to 5-10% then the charge returned to 0% and the display went blank eventually, this was after 10 hrs or so charging with the proper chargers that were shipped with the product!

     

Please sign in to leave a comment.